AbstractViewTableRecordSetUcs(Point3d, Vector3d,
Vector3d) Method
|
Sets the UCS for the view or viewport table
record according to the origin and x- and y-coordinate axes.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetUcs(
Point3d origin,
Vector3d x,
Vector3d y
)
Public Sub SetUcs (
origin As Point3d,
x As Vector3d,
y As Vector3d
)
public:
void SetUcs(
Point3d origin,
Vector3d x,
Vector3d y
)
member SetUcs :
origin : Point3d *
x : Vector3d *
y : Vector3d -> unit
Parameters
- origin Point3d
- [in] UCS origin.
- x Vector3d
- [in] X-axis direction.
- y Vector3d
- [in] Y-axis direction.
See Also