NurbCurve2d(Point2dCollection,
Vector2d, Vector2d, Boolean, Boolean)
Constructor
|
Constructor for the NurbCurve2d class.
Constructs a 2D curve interpolating a given array of 2D points and
using given derivatives at the start point and endpoint.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbCurve2d(
Point2dCollection fitPoints,
Vector2d startTangent,
Vector2d endTangent,
bool startTangentDefined,
bool endTangentDefined
)
Public Sub New (
fitPoints As Point2dCollection,
startTangent As Vector2d,
endTangent As Vector2d,
startTangentDefined As Boolean,
endTangentDefined As Boolean
)
public:
NurbCurve2d(
Point2dCollection^ fitPoints,
Vector2d startTangent,
Vector2d endTangent,
bool startTangentDefined,
bool endTangentDefined
)
new :
fitPoints : Point2dCollection *
startTangent : Vector2d *
endTangent : Vector2d *
startTangentDefined : bool *
endTangentDefined : bool -> NurbCurve2d
Parameters
- fitPoints Point2dCollection
- [in] Array of 2D points through which to fit the curve.
- startTangent Vector2d
- [in] Start tangent vector.
- endTangent Vector2d
- [in] End tangent vector.
- startTangentDefined Boolean
- [in] Flag indicating whether startTangent should be used.
- endTangentDefined Boolean
- [in] Flag indicating whether endTangent should be used.
Remarks
If
startTangentDefined is 0, startTangent is ignored and the
constructor computes the start tangent vector. The same is true for
endTangentDefined.
See Also