EllipticalCylinderSet(Double, Double,
Point3d, Vector3d) Method
|
Sets the specified radii, origin, and axis of
symmetry for this elliptical cylinder.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry
)
Public Sub Set (
minorRadius As Double,
majorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d
)
public:
void Set(
double minorRadius,
double majorRadius,
Point3d origin,
Vector3d axisOfSymmetry
)
member Set :
minorRadius : float *
majorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d -> unit
Parameters
- minorRadius Double
- [in] Minor radius of this elliptical cylinder.
- majorRadius Double
- [in] Major radius of this elliptical cylinder.
- origin Point3d
- [in] Origin point of this elliptical cylinder.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
See Also