DatabaseSaveAs(String, SaveType,
DwgVersion, Boolean, Int32) Method
|
Saves content of the currently active database
according to the passed arguments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SaveAs(
string fileName,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
Public Sub SaveAs (
fileName As String,
st As SaveType,
version As DwgVersion,
saveThumbnailImage As Boolean,
dxfPrecision As Integer
)
public:
void SaveAs(
String^ fileName,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
member SaveAs :
fileName : string *
st : SaveType *
version : DwgVersion *
saveThumbnailImage : bool *
dxfPrecision : int -> unit
Parameters
- fileName String
- [in] File name to write the database to. File extension is not
appended automatically.
- st SaveType
- [in] Save type represented by the SaveType enumeration.
- version DwgVersion
- [in] A file version to which to save the file.
- saveThumbnailImage Boolean
- [in] Flag that indicates whether to save a thumbnail
image.
- dxfPrecision Int32
- [in] .dxf file decimal digits precision. Currently ignored; a
value of 16 is used.
See Also