CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d) Constructor

Constructor for the CurveCurveIntersector3d class. Creates an intersector with two passed curves limited by the specified intervals.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public CurveCurveIntersector3d(
        Curve3d curve1,
        Curve3d curve2,
        Interval range1,
        Interval range2,
        Vector3d planeNormal
)

Parameters

curve1  Curve3d
[in] First curve for the intersection.
curve2  Curve3d
[in] Second curve for the intersection.
range1  Interval
[in] Interval range of the first curve.
range2  Interval
[in] Interval range of the second curve.
planeNormal  Vector3d
[in] Optional normal to a plane to be used in the corresponding C++ object getIntConfigs() method.
See Also

©  Bricsys NV. All rights reserved.