CurveCurveIntersector3d Class

This class represents intersections of 3D curves.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurveCurveIntersector3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class CurveCurveIntersector3d : Entity3d

The CurveCurveIntersector3d type exposes the following members.

Constructors
  Name Description
Public method CurveCurveIntersector3d Default constructor for the CurveCurveIntersector3d class. Creates a default corresponding C++ object with intersection curves set to NULL, default tolerance and flag that indicates whether data is initialized is set to false.
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d) Constructor for the CurveCurveIntersector3d class. Creates an intersector with two passed curves.
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d, Tolerance) Constructor for the CurveCurveIntersector3d class. Creates an intersector with two passed curves and a geometric tolerance.
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d) Constructor for the CurveCurveIntersector3d class. Creates an intersector with two passed curves limited by the specified intervals.
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) Constructor for the CurveCurveIntersector3d class. Creates an intersector with two passed curves limited by the specified intervals.
Top
Properties
  Name Description
Public property Curve1  
Public property Curve2  
Public property NumberOfIntersectionPoints  
Public property PlaneNormal  
Public property Tolerance  
Top
Methods
  Name Description
Public method ChangeCurveOrder Swaps the curve order of the intersector (makes the first curve the second and vice versa).
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetIntersectionParameters Returns intersection parameters of two intersection curves at the specified point of intersection.
Public method GetIntersectionPoint Returns the 3D point at the specified number of intersection point.
Public method GetIntersectionPointTolerance Returns the geometric tolerance used to compute the specified intersection point.
Public method GetIntersectionRanges Gets the intersection ranges of two curves.
Public method GetOverlapRanges Gets the overlap ranges of two curves at the specified overlap index.
Public method GetPointOnCurve1 Gets the specified intersection point as PointOnCurve3d on the first curve.
Public method GetPointOnCurve2 Gets the specified intersection point as PointOnCurve3d on the second curve.
Public method IsTangential Checks whether the curves are tangent at the specified intersection point.
Public method IsTransversal Checks whether the curves are transversal (crossed) at the specified intersection point.
Public method OrderWithRegardsTo1 Sorts the intersection points so they correspond to increasing parameter values of the first curve.
Public method OrderWithRegardsTo2 Sorts the intersection points so they correspond to increasing parameter values of the second curve.
Public method OverlapCount Gets the number of intervals of overlap for the two curves.
Public method OverlapDirection Checks whether the curves are oriented in the same direction where they overlap.
Public method Set(Curve3d, Curve3d, Vector3d) Sets the curves of this intersector.
Public method Set(Curve3d, Curve3d, Vector3d, Tolerance) Sets the curves of this intersector according to a geometric tolerance.
Public method Set(Curve3d, Curve3d, Interval, Interval, Vector3d) Sets the curves of this intersector limited by the specified ranges.
Public method Set(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance) Sets the curves of this intersector limited by the specified ranges.
Top
Remarks
The intersection object links to 3D curve objects but does not contain them. Calculation of the intersection is performed by a query function. If one of the curve objects is deleted, the intersection must be recalculated. For more information, see Working with Intersected Entities.
See Also

©  Bricsys NV. All rights reserved.