EllipticalArc2d(Point2d, Vector2d,
Vector2d, Double, Double, Double, Double) Constructor
|
Constructor for the EllipticalArc2d class.
Creates an elliptical arc by the specified parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public EllipticalArc2d(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point2d,
majorAxis As Vector2d,
minorAxis As Vector2d,
majorRadius As Double,
minorRadius As Double,
startAngle As Double,
endAngle As Double
)
public:
EllipticalArc2d(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
new :
center : Point2d *
majorAxis : Vector2d *
minorAxis : Vector2d *
majorRadius : float *
minorRadius : float *
startAngle : float *
endAngle : float -> EllipticalArc2d
Parameters
- center Point2d
- [in] The center of this elliptical arc.
- majorAxis Vector2d
- [in] The major axis of this elliptical arc.
- minorAxis Vector2d
- [in] The minor axis of this elliptical arc.
- majorRadius Double
- [in] The major radius of this elliptical arc.
- minorRadius Double
- [in] The minor radius of this elliptical arc.
- startAngle Double
- [in] Start angle of this elliptical arc (angle offset from
which arc segments are drawn).
- endAngle Double
- [in] End angle of this elliptical arc (angle offset to which
arc segments are drawn).
See Also