EllipticalArc2d Class

This class represents elliptical arcs and full ellipses in 2D space.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometryEllipticalArc2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class EllipticalArc2d : Curve2d

The EllipticalArc2d type exposes the following members.

Constructors
  Name Description
Public method EllipticalArc2d Default constructor for the EllipticalArc2d class. Creates a default corresponding C++ object with center at the coordinates origin, major axis is kXAxis, minor axis is kYAxis, minor radius and major radius are 1.0, start parameter is equal to 0.0, and end parameter is equal to Oda2PI.
Public method EllipticalArc2d(CircularArc2d) Constructor for the EllipticalArc2d class. Creates an elliptical arc based on the passed circular arc.
Public method EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double) Constructor for the EllipticalArc2d class. Creates an elliptical arc by the specified parameters.
Public method EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) Constructor for the EllipticalArc2d class. Creates an elliptical arc by the specified parameters.
Top
Properties
  Name Description
Public property Center  
Public property EndAngle  
Public property EndPoint  
Public property IsClockWise  
Public property MajorAxis  
Public property MajorRadius  
Public property MinorAxis  
Public property MinorRadius  
Public property StartAngle  
Public property StartPoint  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method IntersectWith(LinearEntity2d) Calculates intersection points with the specified linear entity.
Public method IntersectWith(LinearEntity2d, Tolerance) Calculates intersection points with the specified linear entity according to a geometric tolerance.
Public method IsCircular Checks whether this arc is circular.
Public method IsCircular(Tolerance) Checks whether this arc is circular within a geometric tolerance.
Public method IsInside(Point2d) Checks whether the specified point lies within the full ellipse.
Public method IsInside(Point2d, Tolerance) Checks whether the specified point lies within the full ellipse according to a geometric tolerance.
Public method Set(CircularArc2d) Sets parameters of this elliptical arc by the passed circuilar arc.
Public method Set(Point2d, Vector2d, Vector2d, Double, Double) Sets the specified center, axes and radii for this arc.
Public method Set(Point2d, Vector2d, Vector2d, Double, Double, Double, Double) Sets the specified center, axes, radii and angles for this arc.
Public method SetAngles Sets the specified start and end angles for this elliptical arc.
Public method SetAxes Sets the specified axes for this elliptical arc.
Top
Remarks
The angle of a point on an ellipse is measured by projecting the point along a vector perpendicular to the major axis onto a circle whose center is the center of this ellipse and whose radius is the major radius of this ellipse. The angle between the major axis of this ellipse, and a vector from the center of this ellipse to the intersection point with the circle, measured counterclockwise, is the angle of this point on the ellipse. For more information, see Working with Elliptical Arcs.
See Also

©  Bricsys NV. All rights reserved.