EllipticalArc3dIntersectWith(LinearEntity3d)
Method
|
Calculates intersection points with the
specified linear entity.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] IntersectWith(
LinearEntity3d line
)
Public Function IntersectWith (
line As LinearEntity3d
) As Point3d()
public:
array<Point3d>^ IntersectWith(
LinearEntity3d^ line
)
member IntersectWith :
line : LinearEntity3d -> Point3d[]
Parameters
- line LinearEntity3d
-
Return Value
Point3d
If the method fails or there are no intersection points, this
method returns nullptr. The returned array consists of two
elements. The first element corresponds to the first intersection
point (if it exists), and the second element corresponds to the
second intersection point (if it exists).
See Also