AssocActionAddMoreObjectsToDeepClone
Method
|
Adds more objects to be deep cloned. Call just
before the end of the main deep-cloning loop, when the objects are
already cloned but their identifiers aren't translated yet.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void AddMoreObjectsToDeepClone(
IdMapping idMap,
ObjectIdCollection additionalObjectsToClone
)
Public Sub AddMoreObjectsToDeepClone (
idMap As IdMapping,
additionalObjectsToClone As ObjectIdCollection
)
public:
void AddMoreObjectsToDeepClone(
IdMapping^ idMap,
ObjectIdCollection^ additionalObjectsToClone
)
member AddMoreObjectsToDeepClone :
idMap : IdMapping *
additionalObjectsToClone : ObjectIdCollection -> unit
Parameters
- idMap IdMapping
- [in] Identifier mapping that is used for the current deep
cloning procedure.
- additionalObjectsToClone ObjectIdCollection
- [in] Additional objects on which to perform deep cloning.
Objects that are already cloned are ignored and not cloned
again.
Remarks
The method
inquires whether actions, that have dependencies on objects that
have been cloned, should add more objects to deep clone. The
actions can then report more objects to be deep cloned, and the
main cloning loop continues with deep cloning these additional
objects. This approach continues until there are no more objects to
clone.
See Also