DataCell Class

This class provides a way to represent the following data types in a generic manner: Boolean, integer, double, char*, Point3d, ObjectId, HardOwnershipId, SoftOwnershipId, HardPointerId, and SoftPointerId.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesDataCell

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DataCell : RXObject

The DataCell type exposes the following members.

Constructors
  Name Description
Public method DataCell Default constructor for the DataCell class.
Top
Properties
  Name Description
Public property CellType  
Public property Value  
Top
Methods
  Name Description
Public method Init Sets the data type of this data cell to CellType.Unknown.
Public method SetBool Sets a bool value for this cell.
Public method SetDouble Sets a double value for this cell.
Public method SetHardOwnershipId Sets a hard ownership ID for this cell.
Public method SetHardPointerId Sets a hard pointer ID for this cell.
Public method SetInteger Sets an integer value for this cell.
Public method SetObjectId Sets an object ID for this cell.
Public method SetPoint Sets a 3D point object for this cell.
Public method SetSoftOwnershipId Sets a soft ownership ID value for this cell.
Public method SetSoftPointerId Sets a soft pointer ID value for this cell.
Public method SetString Sets a string value for this cell.
Public method SetVector Sets a vector for this cell.
Top
See Also

©  Bricsys NV. All rights reserved.