SubDMeshExtrudeFaces(FullSubentityPath, Double, Vector3d, Double)
Method
|
Extrudes faces along the given direction and
with a given taper angle.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ExtrudeFaces(
FullSubentityPath[] paths,
double length,
Vector3d dir,
double taper
)
Public Sub ExtrudeFaces (
paths As FullSubentityPath(),
length As Double,
dir As Vector3d,
taper As Double
)
public:
void ExtrudeFaces(
array<FullSubentityPath>^ paths,
double length,
Vector3d dir,
double taper
)
member ExtrudeFaces :
paths : FullSubentityPath[] *
length : float *
dir : Vector3d *
taper : float -> unit
Parameters
- paths FullSubentityPath
- [in] Flag that specifies whether to convert to a smooth
surface. If false, converts to a faceted surface.
- length Double
- [in] Length of extrusion.
- dir Vector3d
- [in] Direction of extrusion.
- taper Double
- [in] Taper angle of extrusion.
See Also