TableSetGridVisibility(Int32,
Int32, GridLineType, Visibility) Method
|
Sets the grid visibility for the specified
cell and edges in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridVisibility(
int row,
int column,
GridLineType gridLineType,
Visibility visibility
)
Public Overridable Sub SetGridVisibility (
row As Integer,
column As Integer,
gridLineType As GridLineType,
visibility As Visibility
)
public:
virtual void SetGridVisibility(
int row,
int column,
GridLineType gridLineType,
Visibility visibility
)
abstract SetGridVisibility :
row : int *
column : int *
gridLineType : GridLineType *
visibility : Visibility -> unit
override SetGridVisibility :
row : int *
column : int *
gridLineType : GridLineType *
visibility : Visibility -> unit
Parameters
- row Int32
- [in] Row index.
- column Int32
-
- gridLineType GridLineType
- [in] Gridline types.
- visibility Visibility
- [in] Visibility status.
Remarks
The gridLineType
parameter can be one of the following:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also