NurbCurve2d(Point2dCollection,
Tolerance) Constructor
|
Constructor for the NurbCurve2d class.
Constructs a 2D curve interpolating a given array of 2D points
within a given tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbCurve2d(
Point2dCollection fitPoints,
Tolerance fitTolerance
)
Public Sub New (
fitPoints As Point2dCollection,
fitTolerance As Tolerance
)
public:
NurbCurve2d(
Point2dCollection^ fitPoints,
Tolerance fitTolerance
)
new :
fitPoints : Point2dCollection *
fitTolerance : Tolerance -> NurbCurve2d
Parameters
- fitPoints Point2dCollection
- [in] Array of 2D points through which to fit the curve.
- fitTolerance Tolerance
- [in] Maximum deviation of the curve from the fit points.
See Also