MlineGetClosestPointTo(Point3d,
Vector3d, Boolean, Boolean) Method
|
Finds and returns the closest point to this
Mline object projected on the specified plane.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d GetClosestPointTo(
Point3d givenPoint,
Vector3d normal,
bool extend,
bool excludeCaps
)
Public Function GetClosestPointTo (
givenPoint As Point3d,
normal As Vector3d,
extend As Boolean,
excludeCaps As Boolean
) As Point3d
public:
Point3d GetClosestPointTo(
Point3d givenPoint,
Vector3d normal,
bool extend,
bool excludeCaps
)
member GetClosestPointTo :
givenPoint : Point3d *
normal : Vector3d *
extend : bool *
excludeCaps : bool -> Point3d
Parameters
- givenPoint Point3d
- [in] Point for which to find the closest point.
- normal Vector3d
- [in] Normal to the projection plane.
- extend Boolean
- [in] Flag that indicates whether to extend Mline geometry.
- excludeCaps Boolean
- [in] Flag that indicates whether to exclude Mline start/end
caps and joints.
Return Value
Point3d
See Also