Creates a solid by revolving the specified
region around the axis. The axis is specified with a point and
vector.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Revolve(
Region region,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution
)
Public Overridable Sub Revolve (
region As Region,
axisPoint As Point3d,
axisDir As Vector3d,
angleOfRevolution As Double
)
public:
virtual void Revolve(
Region^ region,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution
)
abstract Revolve :
region : Region *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float -> unit
override Revolve :
region : Region *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float -> unit
Parameters
- region Region
- [in] Region to revolve.
- axisPoint Point3d
- [in] Point on the axis of revolution.
- axisDir Vector3d
- [in] Vector defining the axis of revolution.
- angleOfRevolution Double
- [in] Angle of revolution in radians.
Remarks
The axis of
revolution is projected onto the plane of the region, parallel to
its normal. The revolution axis must be valid for a rotation of the
region: axisDir is not perpendicular to the plane of a region,
axisDir does not pass through a region, etc. The following
constraints are applied: * The projected axis of revolution cannot
intersect the region. * angleOfRevolution >= 1e-6. This method
is implemented only for the Spatial modeler.
See Also