DatabasePurge(ObjectIdCollection) Method

Removes the object IDs from the specified array that are hard referenced in this database object. After method execution, the ids array contains only object ID entities of objects that are not currently hard-referenced and thus can safely be erased.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void Purge(
        ObjectIdCollection ids
)

Parameters

ids  ObjectIdCollection
[in/out] Collection of identifiers to check.
Remarks
Any remaining object identifiers can be safely erased. This method does not modify the database.
See Also

©  Bricsys NV. All rights reserved.