TransformOverruleExplode Method

Explodes the specified entity into a set of simpler entities.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void Explode(
        Entity entity,
        DBObjectCollection entitySet
)

Parameters

entity  Entity
[in] Entity to explode.
entitySet  DBObjectCollection
[in/out] Receives a collection of new entities. May contain elements before method execution; new elements are appended to the end of the collection.
Remarks
Entities resulting from the explosion are appended to the specified collection. The newly created entities are not database-resident. The default implementation of this method throws the eNotApplicable exception. This method can be overridden in custom classes.
See Also

©  Bricsys NV. All rights reserved.