Returns the 2D point with the coordinates
corresponding to the decomposition of the vector * this - p in the
basis uAxis, vAxis of the planar entity, where p, uAxis, and vAxis
can be found by the function call plane.get(p, uAxis, vAxis).
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point2d Convert2d(
PlanarEntity plane
)
Public Function Convert2d (
plane As PlanarEntity
) As Point2d
public:
Point2d Convert2d(
PlanarEntity^ plane
)
member Convert2d :
plane : PlanarEntity -> Point2d
Parameters
- plane PlanarEntity
- [in] A plane on which this point lies.
Return Value
Point2d
A converted 2D point.
Remarks
This 3D point is
assumed to be on the specified plane.
See Also