LineAngularDimension2(Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId) Constructor

Constructor. Creates a LineAngularDimension2 object with specified parameters.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public LineAngularDimension2(
        Point3d line1Start,
        Point3d line1End,
        Point3d line2Start,
        Point3d line2End,
        Point3d arcPoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

line1Start  Point3d
[in] Start point of the first definition line.
line1End  Point3d
[in] End point of the first definition line which is the start point for the first extension line.
line2Start  Point3d
[in] Start point of the second definition line.
line2End  Point3d
[in] End point of the second definition line which is the start point for the second extension line.
arcPoint  Point3d
[in] Point lying on the dimension arc.
dimensionText  String
[in] Dimension text to replace the measured value text.
dimensionStyle  ObjectId
[in] ObjectId of the dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.