Line
|
The LineAngularDimension2 type exposes the following members.
Name | Description | |
---|---|---|
![]() |
LineAngularDimension2 | Default constructor. Creates a two-line angular dimension entity with an arc point and extension lines 1 and 2 with start points at (0,0,0). |
![]() |
LineAngularDimension2(IntPtr, Boolean) | Initializes a new instance of the LineAngularDimension2 class |
![]() |
LineAngularDimension2(Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId) | Constructor. Creates a LineAngularDimension2 object with specified parameters. |
Name | Description | |||||||||||||||||||||||||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
![]() |
AcadObject | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AlternatePrefix | Sets or gets the prefix for alternate dimension
measurements. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AlternateSuffix | Sets or gets the suffix for alternate dimension
measurements. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressLeadingZeros | Sets or gets the suppression of leading zeros in alternate
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressTrailingZeros | Sets or gets the suppression of trailing zeros in alternate
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressZeroFeet | Sets or gets the suppression of zero-foot measurements in
alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressZeroInches | Sets or gets the suppression of zero-inch measurements in
alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressLeadingZeros | Sets or gets the suppression of leading zeros for tolerance
values in alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressTrailingZeros | Sets or gets the suppression of trailing zeros for tolerance
values in alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressZeroFeet | Sets or gets the suppression of zero-foot measurements for
tolerance values in alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressZeroInches | Sets or gets the suppression of zero-inch measurements for
tolerance values in alternate dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Annotative | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ArcPoint | Sets or gets the three-dimensional WCS coordinates of the point defining the location of the dimension arc for this dimension entity. | ||||||||||||||||||||||||||||||||||||||||
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
||||||||||||||||||||||||||||||||||||||||
![]() |
BlockId | Property that represents an object identifier of a block that
stores this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
BlockName | Property that represents the name of a block that owns this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Bounds | (Inherited from Drawable) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CastShadows | Property that indicates whether this entity casts
shadows. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CenterMarkSize | Gets the center mark size for radial and diameter
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CenterMarkType | Gets the center mark type for radial and diameter
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ClassID | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CloneMeForDragging | Property that represents the cloneMeForDragging flag. This flag indicates whether
a clone of this entity should be created for drag operations. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CollisionType | Property that represents a collision type for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Color | Property that represents color for this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ColorIndex | Property that represents a color index for this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CompoundObjectTransform | Property that represents a transformation matrix for compound
objects (these objects return the DrawableIsCompoundObject flag from the subSetAttributes() method). The returned matrix is
the same matrix that is passed to pushModelTransform() before rendering nested
objects. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CurrentMeasurement | Stores the measured value in the specified units as a Double
value. For linear dimensions it is a length, for angular dimensions
it is an angle. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Database | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimadec | Sets or gets the number of decimal places in the angular
measured value and angular tolerance.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalt | Controls the display of alternate measurements in
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltd | Sets or gets the number of decimal places for alternate
measurements in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltf | Sets or gets the scale factor for alternate linear units. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltrnd | Sets or gets the real number to round alternate measured values
(not tolerance values). (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalttd | Sets or gets the number of decimal places for alternate
tolerance values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalttz | Sets or gets the suppression of zeros in alternate tolerance
values in dimension.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltu | Sets or gets the format of alternate units.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltz | Sets or gets the suppression of zeros in alternate measurements
in dimensions.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimapost | Sets or gets a text suffix or prefix or both for dimension
alternate measurements. Dimpost is in the form
prefix<>suffix. The '<>' in Dimpost is
replaced by the alternate measurements text. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimarcsym | Sets or gets the type of arc symbol used within the dimension
text of the arc length dimension entity.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimasz | Sets or gets the size of dimension lines arrowheads. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimatfit | Sets or gets how arrows and text are placed when they do not
fit within the extension lines of dimensions.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaunit | Sets or gets the format for the angular measured value and
angular tolerance value.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimazin | Sets or gets the suppression of zeros in angular measured
values and tolerance.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk | Sets or gets an ObjectId of the block that form arrowheads for
dimension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk1 | Sets or gets an ObjectId of the block that form arrowheads for
the first dimension line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk1s | Sets or gets the name of the arrowhead block at the end of the
first dimension line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk2 | Sets or gets an ObjectId of the block that form arrowheads for
the second dimension line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk2s | Sets or gets the name of the arrowhead block at the end of the
second dimension line. The following names are applicable:
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblks | Sets or gets the name of the arrowhead block at the ends of
dimension lines. The following names are applicable:
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimBlockId | Sets or gets an ObjectId of the BlockTableRecord object
associated with the dimension entity. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimBlockPosition | Sets or gets the WCS relative position of the block that is
associated with the dimension entity. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimcen | Controls the generation of arc and circle center marks and
lines. The absolute value of Dimcen specifies the size of the
center mark, which half the length of the center mark, which is
also the length of the portion of a center line beyond the arc or
circle, as well as the length of the gap between the center mark
and line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclrd | Sets or gets the color for the leader line, arrowheads, and
both dimension lines and their extensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclre | Sets or gets the color for the extension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclrt | Sets or gets the color of the dimension text. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdec | Sets or gets the number of decimal places in the primary
measured value and tolerance. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdle | Sets or gets the length of the distance that dimension lines
are extended beyond extension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdli | Sets or gets distance between dimension lines for baseline
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdsep | Sets or gets the character to use as the decimal separator as a
char value. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionStyle | Sets or gets the ObjectId for the DimStyleTableRecord object
associated with the Dimension object. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionStyleName | Gets or sets the name of a dimension style. Setting the
DimensionStyleName assigns the DimensionStyle of this style name to
the dimension if the style exists, or an exception will be thrown
if there is no style with such name. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionText | Sets or gets the text string that replaces the measured value.
If the DimensionText property is an empty string, which is the
default value, the dimension entity represents the measured
value. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimexe | Sets or gets the length of the distance that extension lines
are extended beyond dimension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimexo | Sets or gets the distance that extension lines are offset from
their origin points. Dimexo specifies a minimum value when
fixed-length extension lines are used. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimfrac | Sets or gets the fractional format. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimfxlen | Sets or gets the length of extension lines. The extension line
length is the distance between the beginning of an extension line
and the cross-point with a dimension line. The extension and offset
are not included in the length. If the extension line length is a
negative value, extension lines are drawn from the outside to the
cross-points with dimension lines, towards the extension
points. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimfxlenOn | Sets or gets whether extension lines have a fixed length. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimgap | Sets or gets the distance between the dimension text box and
the dimension, extension, or leader line according to the text
position and text movement. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimjogang | Sets and gets the jog angle of dimension lines in jogged radius
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimjust | Sets or gets the horizontal justification for the dimension
text box (relative to the extension lines).
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimldrblk | Sets or gets the arrowhead block at the ends of leader lines. A
null value specifies the default arrowhead is to be used. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimldrblks | Sets or gets the name of the arrowhead block at the ends of
leader lines. The following names are applicable:
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlfac | Sets or gets the linear scale factor, a positive non-zero
Double value, that influences the measured value. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlim | Sets or gets whether the limits are generated as the dimension
text. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltex1 | Sets or gets the linetype of the first extension line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltex2 | Sets or gets the linetype of the second extension line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltype | Sets or gets the linetype of the leader line, both dimension
lines, and their extensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlunit | (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlwd | Sets or gets the lineweight for the leader line, both dimension
lines, and their extensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlwe | Sets or gets the lineweight assigned to both the first and
second extension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimpost | Sets or gets a text suffix or prefix or both for dimension
primary measurements. Dimpost is in the form
prefix<>suffix. The '<>' in Dimpost is
replaced by the primary measurements text. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimrnd | Sets or gets the real number to round the primary measured
values (not tolerance values). For example, if the rounding is set
to 0.04, the value will be rounded to the nearest 0.04 unit. Thus,
1.912 becomes 1.92, 1.935 becomes 1.92, 1.945 becomes 1.96, and
1.972 becomes 1.96. If the rounding is set to 1.0, the value will
be rounded to the nearest integer value. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsah | Sets and gets whether blocks set by the Dimblk1 and Dimblk2 or
a block set by the Dimblk are used as the arrowheads for the
dimension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimscale | Sets and gets the scale factor applied to all dimension
variables that regulates sizes, offsets, and distances. The scale
factor does not affect the measured lengths, angles, or
coordinates. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsd1 | Controls the suppression of the first dimension line and
arrowhead in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsd2 | Controls the suppression of the second dimension line and
arrowhead in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimse1 | Controls the suppression of the first extension line
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimse2 | Controls the suppression of the second extension line
dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsoxd | Controls the suppression of dimension lines outside the
extension lines. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtad | Sets or gets the vertical justification for the dimension text.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtdec | Sets or gets the number of decimal places in tolerance values
for primary units in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfac | Sets or gets as a factor of Dimtxt, the size of tolerance text
in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfill | Sets or gets the background fill of dimension text.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfillclr | Sets or gets the background color to fill a dimension text
box. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtih | Sets or gets the orientation of dimension text inside the
extension lines. If the Dimtih property is true, the dimension text
box is horizontally aligned. If Dimtih is false, the dimension text
box is aligned with the dimension line or leader line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtix | Sets or gets the placement of a dimension text box between the
extension lines of a dimension entity. If the Dimtix property is
true, the dimension text box is required to be placed between
extension lines. If Dimtix is false, the dimension text box is
placed between extension lines only if there is sufficient
space. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtm | Sets or gets the lower tolerance limit for dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtmove | Sets or gets the method of movement for a dimension text box
and dimension lines relative to one to another while dragging.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtofl | Controls the drawing of a forced line inside extension lines or
the definition entity when dimension lines are placed outside of
the extension lines or definition entity. This property is true if
a forced line is drawn inside (dimension lines are connected) or
false if a forced line is not drawn (dimension lines are
open-ended). (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtoh | Controls the orientation of dimension text outside the
extension lines or definition entity. If Dimtoh property is true,
the dimension text box is horizontally aligned when it is placed
outside the extension lines or definition entity. If Dimtoh
property is false, the dimension text box is aligned along the
dimension line or leader line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtol | Controls the generation of tolerance text in dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtolj | Sets or gets the vertical justification of the tolerance text
box relative to the dimension text box.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtp | Sets or gets the upper tolerance limit for dimensions. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtsz | Sets or gets the size of oblique strokes to be drawn instead of
arrowheads for linear, radial, and diameter dimensions. Dimtsz is
the distance, parallel to the dimension line, that the tics extend
beyond the extension lines. If Dimtsz = 0, the arrowheads will be
drawn. Positive values determine the size of oblique strokes. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtvp | Sets or gets, as a factor of Dimtxt, the vertical distance of
the middle of the dimension text with respect to the dimension
line. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtxt | Sets or gets the dimension text size. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtzin | Sets or gets the suppression of zeros in primary tolerance
values in dimension.
(Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimupt | Controls the movement of user-positioned text when dimension
lines are moved. Dimupt is true if the dimension line and the text
move, and false if only the dimension line moves. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimzin | Sets or gets the suppression of zeros in primary measured
values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Drawable | Property that represents a drawable that is associated with
this object. (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DrawableType | (Inherited from Drawable) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DynamicDimension | Sets or gets whether the dimension entity is a dynamic
dimension. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Ecs | Property that represents the entity coordinate system
matrix. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
EdgeStyleId | Property that represents an object identifier of an edge
style. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Elevation | Sets or gets the elevation of this entity. Elevation is the
distance from the WCS origin to the plane of this entity. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
EntityColor | Property that represents an entity color value for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ExtensionDictionary | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
FaceStyleId | Property that represents an object identifier of a face
style. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ForceAnnoAllVisible | (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
GeometricExtents | Property that represents geometric extents for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Handle | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
HasFields | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
HasSaveVersionOverride | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
HorizontalRotation | Sets or gets the rotation angle of a dimension entity in the
range from 0 to 2*PI radians. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Hyperlinks | Property that represents a collection of hyperlinks associated
with this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Id | Property that represents an object identifier of this database
object. (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsAProxy | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsCancelling | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsErased | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsEraseStatusToggled | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsModified | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsModifiedGraphics | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsModifiedXData | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsNewObject | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsNotifyEnabled | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsNotifying | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsObjectIdsInFlux | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsPersistent | Property that indicates whether this object is a
database-resident (DBRO). Persistent objects belong to an object
that must be opened and closed. Non-persistent objects can be
accessed through their pointers. (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsPlanar | Property that indicates whether this entity is planar. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsReadEnabled | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsReallyClosing | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsTransactionResident | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsUndoing | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
IsWriteEnabled | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Layer | Property that represents a layer name for this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
LayerId | Property that represents an object identifier of a layer for
this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Linetype | Property that represents the linetype attribute for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
LinetypeId | Property that represents a linetype attribute for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
LinetypeScale | Property that represents a scale factor of a linetype for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
LineWeight | Property that represents a lineweight attribute for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Material | Property that represents a material for this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
MaterialId | Property that represents an object identifier of a material for
this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
MaterialMapper | Property that represents a material mapper for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Measurement | Stores the measured value in the specified units as a Double
value. For linear dimensions it is a length, for angular dimensions
it is an angle. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
MergeStyle | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Normal | Sets or gets the three-dimensional WCS coordinates of the
normal vector. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ObjectBirthVersion | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ObjectId | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
OwnerId | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
PaperOrientation | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
PlotStyleName | Property that represents the plot style name for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
PlotStyleNameId | Property that represents a descriptor of the plot style used
for this entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Prefix | Sets or gets the prefix for primary dimension
measurements. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ReceiveShadows | Property that indicates whether this entity receives
shadows. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Suffix | Sets or gets the suffix for primary dimension
measurements. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressAngularLeadingZeros | Sets or gets the suppression of leading zeros in angular
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressAngularTrailingZeros | Sets or gets the suppression of trailing zeros in angular
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressLeadingZeros | Sets or gets the suppression of leading zeros in primary
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressTrailingZeros | Sets or gets the suppression of trailing zeros in primary
dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressZeroFeet | Sets or gets the suppression of zero-foot measurements in
primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressZeroInches | Sets or gets the suppression of zero-inch measurements in
primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextAttachment | Sets or gets the dimension text justification mode within the
text box. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextLineSpacingFactor | Sets or gets the relative distance between adjoining base lines
of text strings. The line spacing factor can have a value in the
range of 0.25 to 4.0. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextLineSpacingStyle | Sets or gets the dimension text line spacing style for this
Dimension object. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextPosition | Sets or gets the three-dimensional coordinates of the text
position as a Point3d value. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextRotation | Sets or gets the rotation angle of a dimension text box in
radians. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextStyleId | Sets or gets the text style of the dimension text. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressLeadingZeros | Sets or gets the suppression of leading zeros for tolerance
values in primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressTrailingZeros | Sets or gets the suppression of trailing zeros for tolerance
values in primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressZeroFeet | Sets or gets the suppression of zero-foot measurements for
tolerance values in primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressZeroInches | Sets or gets the suppression of zero-inch measurements for
tolerance values in primary dimension values. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Transparency | Property that represents the transparency attribute for this
entity. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
UndoFiler | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
||||||||||||||||||||||||||||||||||||||||
![]() |
UsingDefaultTextPosition | Defines whether the default position is used for dimension text
or not. If true then the default text position is used. To set a
new text position, the false value must be set. (Inherited from Dimension) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Visible | Property that indicates whether this entity is visible. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
VisualStyleId | Property that represents an object identifier of a visual
style. (Inherited from Entity) |
||||||||||||||||||||||||||||||||||||||||
![]() |
XData | (Inherited from DBObject) |
||||||||||||||||||||||||||||||||||||||||
![]() |
XLine1End | Sets or gets the end point of the first definition line. The end point of the first definition line defines the start point for the first extension line. | ||||||||||||||||||||||||||||||||||||||||
![]() |
XLine1Start | Sets or gets the start point of the first definition line. | ||||||||||||||||||||||||||||||||||||||||
![]() |
XLine2End | Sets or gets the end point of the second definition line. The end point of the second definition line defines the start point for the second extension line. | ||||||||||||||||||||||||||||||||||||||||
![]() |
XLine2Start | Sets or gets the start point of the second definition line. |
Name | Description | |
---|---|---|
![]() |
AddContext | Adds a copy of a context to the object. (Inherited from DBObject) |
![]() |
AddPersistentReactor | Adds the specified persistent reactor to this object's reactor
list. (Inherited from DBObject) |
![]() |
AddSubentityPaths | Adds one or more subentities to this entity. (Inherited from Entity) |
![]() |
ApplyPartialUndo | Notification method that is called each time this object uses
the partial undo mechanism. (Inherited from DBObject) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject) |
![]() |
AssertReadEnabled | (Inherited from DBObject) |
![]() |
AssertWriteEnabled | (Inherited from DBObject) |
![]() |
Audit | Performs an audit operation on this object. (Inherited from DBObject) |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. Calculates the bounding box for this entity and then finds the intersections of the passed entity and all the edges of the bounding box of this entity. (Inherited from Entity) |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | Calculates the bounding box for this entity and then finds the
intersections of the passed entity and all the edges of the
bounding box of this entity. (Inherited from Entity) |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity. (Inherited from Entity) |
![]() |
BoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | Projects the bounding box edges of this entity and the passed
entity on the projection plane, calculates the bounding box for
this entity, and then finds the intersection points and projects
intersections back to the bounding box edge of this entity. (Inherited from Entity) |
![]() |
Cancel | Obsolete. Terminates the current open operation. Currently not implemented. (Inherited from DBObject) |
![]() |
Clone | (Inherited from RXObject) |
![]() |
Close | Obsolete. Closes the object. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CloseAndPage | Obsolete. Closes the object and pages it if the object pager is enabled. All changes made to the object since it was opened are committed to the database and a notification is sent that the object is now "closed". Currently not implemented. (Inherited from DBObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateExtensionDictionary | Creates a DbDictionary extension dictionary of this
object. (Inherited from DBObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DecomposeForSave | Determines the behavior for custom objects when saving to a
.dwg file. (Inherited from DBObject) |
![]() |
DeepClone | Performs a deep clone of this object. (Inherited from DBObject) |
![]() |
DeleteSubentityPaths | Removes one or more subentities from this entity. (Inherited from Entity) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject) |
![]() |
DisableUndoRecording | Controls the undo recording of this object in
OdDbDatabase. (Inherited from DBObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DBObject) |
![]() |
DowngradeOpen | Downgrades this object from ForWrite
to ForRead. (Inherited from DBObject) |
![]() |
DowngradeToNotify | Downgrades this object from ForNotify
and ForWrite to having just one open mode
- ForNotify. Currently not
implemented. (Inherited from DBObject) |
![]() |
Draw | Queues up the entity's graphics and flushes the graphics queue,
forcing the queue elements to be drawn or re-drawn. (Inherited from Entity) |
![]() |
DwgIn | Reads the .dwg file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DwgInFields | (Inherited from DBObject) |
![]() |
DwgOut | Writes the .dwg file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DwgOutFields | (Inherited from DBObject) |
![]() |
DxfIn | Reads the .dxf file format data of this object from the
specified file. (Inherited from DBObject) |
![]() |
DxfInFields | (Inherited from DBObject) |
![]() |
DxfOut | Writes the .dxf file format data of this object to the
specified filer. (Inherited from DBObject) |
![]() |
DxfOutFields | (Inherited from DBObject) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Erase | Marks this object as "erased". (Inherited from DBObject) |
![]() |
Erase(Boolean) | Sets the erased mode of this object. (Inherited from DBObject) |
![]() |
Explode | Explodes this entity into a set of simpler entities. (Inherited from Entity) |
![]() |
ExplodeGeometry | Explodes this entity into a set of simpler entities. (Inherited from Entity) |
![]() |
ExplodeGeometryToBlock(BlockTableRecord) | Explodes this entity into a set of simpler entities and adds
them to the specified block. (Inherited from Entity) |
![]() |
ExplodeGeometryToBlock(BlockTableRecord, ObjectIdCollection) | Explodes this entity into a set of simpler entities and adds
them to the specified block. (Inherited from Entity) |
![]() |
ExplodeGeometryToOwnerSpace | Explodes this entity into a set of simpler entities and adds
them to the owner block. (Inherited from Entity) |
![]() |
FieldFromMText | Copies a text field from a specified MText object, if it
contains the field, and adds the copy to this Dimension
object. (Inherited from Dimension) |
![]() |
FieldToMText | Copies a text field from this Dimension object, if it contains
the field, and adds the copy to the specified MText object. (Inherited from Dimension) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
FormatMeasurement | Returns an MText string that represents the formatted
measurement of a dimension entity. (Inherited from Dimension) |
![]() |
GenerateLayout | Updates the dimension according to the current dimension style,
similar to the Dim, Update subcommand. Currently not
implemented. (Inherited from Dimension) |
![]() |
GetDimstyleData | Copies the dimension style settings, including overrides, of
this Dimension object into the specified dimension style table
record. (Inherited from Dimension) |
![]() |
GetEventExtender | (Inherited from DBObject) |
![]() |
GetField | Returns the object ID of a "TEXT" field object from the field
dictionary. (Inherited from DBObject) |
![]() |
GetField(String) | Returns the object ID of the specified field object (that
matches the property name) from the field dictionary. (Inherited from DBObject) |
![]() |
GetGraphicsMarkersAtSubentityPathIntPtr | Entities use a mechanism of graphics system markers to draw
themselves. This mechanism associates an integer identifier called
a graphics system marker (or, GS marker) with each primitive or
with groups of primitives. Using specific selection mechanisms, the
GS marker for the actual subentity selected on the screen can be
retrieved and used for various purposes, for example
highlighting/unhighlighting the subentity on the screen,
hiding/unhiding it, etc. This method returns all graphics system
markers by subentity paths for complex entities that have the
ability to associate an integer identifier (GS marker) with each
graphics primitive or with groups of primitives during the
draw. (Inherited from Entity) |
![]() |
GetGripPoints(Point3dCollection, IntegerCollection, IntegerCollection) | Returns all grip points of this entity. (Inherited from Entity) |
![]() |
GetGripPoints(GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) | Returns all grip points of this entity. (Inherited from Entity) |
![]() |
GetGripPointsAtSubentityPath | Gets the grip points and supporting information about the grips
for a subentity. (Inherited from Entity) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetObjectSaveVersion(DwgFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetObjectSaveVersion(DxfFiler) | Returns the drawing and maintenance release version into which
this object must be stored. (Inherited from DBObject) |
![]() |
GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) | Returns all appropriate object snap points of this
entity. (Inherited from Entity) |
![]() |
GetObjectSnapPoints(ObjectSnapModes, Int32, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) | Returns all appropriate object snap points of this
entity. (Inherited from Entity) |
![]() |
GetPersistentReactorIds | Returns the object IDs of this object's persistent
reactors. (Inherited from DBObject) |
![]() |
GetPlane | Returns the plane on which this entity lies. (Inherited from Entity) |
![]() |
GetReactors | Obsolete. Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetStretchPoints | Returns all stretch points of this entity. (Inherited from Entity) |
![]() |
GetSubentity | Returns a subentity specified by its full path. (Inherited from Entity) |
![]() |
GetSubentityGeometricExtents | Returns the geometric extents for a subentity. (Inherited from Entity) |
![]() |
GetSubentityPathsAtGraphicsMarker(SubentityType, IntPtr, Point3d, Matrix3d, ObjectId) | Returns all subentity paths by the graphic system marker for
complex entities that have the ability to associate an integer
identifier (GS marker) with each graphic primitive or with groups
of primitives during drawing. (Inherited from Entity) |
![]() |
GetSubentityPathsAtGraphicsMarker(SubentityType, Int32, Point3d, Matrix3d, Int32, ObjectId) | Obsolete. Returns all subentity paths by the graphics system marker for complex entities that have the ability to associate an integer identifier (GS marker) with each graphic primitive or with groups of primitives during drawing. (Inherited from Entity) |
![]() |
GetTransformedCopy | Creates a copy of this entity, applies the passed
transformation to the newly created copy, and returns the
copy. (Inherited from Entity) |
![]() |
GetTransientReactors | Returns this object's transient reactors. (Inherited from DBObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
GetXDataForApplication | Returns a linked list of ResBufs containing a copy of the XData
of this object. (Inherited from DBObject) |
![]() |
HandOverTo | Replaces this database-resident (DBRO) object with the
specified non-database-resident (NDBRO) object, while retaining
this object's objectId, handle, owner, and reactor list. (Inherited from DBObject) |
![]() |
HasContext | Checks whether the specified context exists in the
collection. (Inherited from DBObject) |
![]() |
HasPersistentReactor | Checks whether the passed identifier is an identifier of a
reactor attached to this object. (Inherited from DBObject) |
![]() |
Highlight | Highlights this entity. (Inherited from Entity) |
![]() |
Highlight(FullSubentityPath, Boolean) | Highlights the specified subentity path for this entity. (Inherited from Entity) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
IntersectWith(Entity, Intersect, Point3dCollection, Int32, Int32) | Obsolete. Intersects this entity with another entity if possible. (Inherited from Entity) |
![]() |
IntersectWith(Entity, Intersect, Point3dCollection, IntPtr, IntPtr) | Intersects this entity with another entity if possible. (Inherited from Entity) |
![]() |
IntersectWith(Entity, Intersect, Plane, Point3dCollection, Int32, Int32) | Obsolete. Projects this entity on the specified plane, calculates intersection points with the specified entity, and projects intersection points back to the entity. (Inherited from Entity) |
![]() |
IntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) | Projects this entity on the specified plane, calculates
intersection points with the specified entity, and projects
intersection points back to the entity. (Inherited from Entity) |
![]() |
IsContentSnappable | Checks whether the containing block is to be investigated for
osnaps (object snapping) points. (Inherited from Entity) |
![]() |
JoinEntities | (Inherited from Entity) |
![]() |
JoinEntity | (Inherited from Entity) |
![]() |
List | This method is triggered by the standard LIST command and
displays the DXF format contents of the entity to the
display. (Inherited from Entity) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
MoveGripPointsAt(IntegerCollection, Vector3d) | Moves the specified grip points of this entity. (Inherited from Entity) |
![]() |
MoveGripPointsAt(GripDataCollection, Vector3d, MoveGripPointsFlags) | Applies a vector offset to one or more grip points. (Inherited from Entity) |
![]() |
MoveGripPointsAtSubentityPaths | Applies a vector offset to one or more grip points exposed by
the subentities of the object. (Inherited from Entity) |
![]() |
MoveStretchPointsAt | Moves the specified stretch points of this entity. (Inherited from Entity) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
RecomputeDimensionBlock | Recomputes the dimension block referenced by this Dimension
entity to reflect any changes made to the dimension entity since
the last time the block table record was updated. (Inherited from Dimension) |
![]() |
RecordGraphicsModified | Sets the bit flag indicating that the entity's geometry is
changed. (Inherited from Entity) |
![]() |
RegenSupportFlags | (Inherited from Drawable) |
![]() |
ReleaseExtensionDictionary | Releases and erases this object's extension dictionary if it
exists and is empty. (Inherited from DBObject) |
![]() |
RemoveContext | Removes a context from the collection. An active context can't
be removed. (Inherited from DBObject) |
![]() |
RemoveField | Removes the text field and returns its field ID. (Inherited from DBObject) |
![]() |
RemoveField(ObjectId) | Removes the specified field. (Inherited from DBObject) |
![]() |
RemoveField(String) | Removes the specified field by its name and returns its
ID. (Inherited from DBObject) |
![]() |
RemovePersistentReactor | Removes the specified persistent reactor from this object's
reactor list. (Inherited from DBObject) |
![]() |
RemoveTextField | Removes a text field from this Dimension object, if it contains
the field. (Inherited from Dimension) |
![]() |
ResetScaleDependentProperties | Resets object properties that depend on scale to the default
values. (Inherited from DBObject) |
![]() |
SaveAs | Creates a geometric representation of this entity for saving
proxy graphics or converting to previous formats. (Inherited from Entity) |
![]() |
SetAttributes | Sets the vectorization attributes of this object, and returns
its attribute flags. (Inherited from Drawable) |
![]() |
SetDatabaseDefaults | Applies the default properties to this entity from the database
where this entity is stored or from the host application
database. (Inherited from Entity) |
![]() |
SetDatabaseDefaults(Database) | Applies the default properties to this entity from the
specified database. (Inherited from Entity) |
![]() |
SetDimstyleData | Copies the dimension style settings, including overrides, from
the specified dimension style table record to this Dimension
object. (Inherited from Dimension) |
![]() |
SetDragStatus | Notification function called when this entity is involved in a
drag operation. (Inherited from Entity) |
![]() |
SetField(Field) | Sets the specified field for the "TEXT" property. (Inherited from DBObject) |
![]() |
SetField(String, Field) | Sets the specified field for the specified property. (Inherited from DBObject) |
![]() |
SetFromStyle | Sets the annotative property of an object according to its
corresponding style, such as styles of text objects. (Inherited from DBObject) |
![]() |
SetGripStatus | Notification function called when this entity is involved in a
grip operation. (Inherited from Entity) |
![]() |
SetLayerId | Sets the layer to be referenced by this entity (DXF 8). (Inherited from Entity) |
![]() |
SetObjectIdsInFlux | Called on a newly created cloned object to indicate that its
object ID is not valid. (Inherited from DBObject) |
![]() |
SetPaperOrientation | Sets the paper orientation property of a specified
object. (Inherited from DBObject) |
![]() |
SetPropertiesFrom | Creates a geometric representation of this entity for saving
proxy graphics or converting to previous formats. (Inherited from Entity) |
![]() |
SetSubentityGripStatus | The notification method called just before grips for the
subentity are deleted from the host application. The status parameter indicates that the grips for the
entity have been deleted from the host application and the entity
does not participate in any grip edit operations. (Inherited from Entity) |
![]() |
SubRegenSupportFlags | (Inherited from Drawable) |
![]() |
SubSetAttributes | (Inherited from DBObject) |
![]() |
SubViewportDraw | (Inherited from DBObject) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject) |
![]() |
SubWorldDraw | (Inherited from DBObject) |
![]() |
SupportsCollection | Checks whether a particular context type is supported by this
object. This method shows whether an object supports a collection
type but does not show whether this object participates in any
contexts of that type. (Inherited from DBObject) |
![]() |
SwapIdWith | Swaps the objectIDs, handles, extended data (XData), and
extension dictionary between this object and another object. (Inherited from DBObject) |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
maps in two different calls to this method. Currently not
implemented. (Inherited from DBObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TransformBy | Applies the specified 3D transformation matrix to this
entity. (Inherited from Entity) |
![]() |
TransformSubentityPathsBy | Applies a geometric transformation to one or more subentities
of an object. (Inherited from Entity) |
![]() |
Unhighlight | Unhighlights this entity. (Inherited from Entity) |
![]() |
Unhighlight(FullSubentityPath, Boolean) | Unhighlights the specified subentity path for this
entity. (Inherited from Entity) |
![]() |
UpgradeFromNotify | Upgrades the object from at least ForNotify mode to both ForNotify and ForWrite
modes. You should place a call to DowngradeToNotify() with no Open() or Close() methods
in between. For internal use. Currently not implemented. (Inherited from DBObject) |
![]() |
UpgradeOpen | (Inherited from DBObject) |
![]() |
ViewportDraw | Creates a viewport-dependent geometric representation of this
object. (Inherited from Drawable) |
![]() |
ViewportDrawLogicalFlags | Retrieves the setAttributes flags for the current
viewportDraw. (Inherited from Drawable) |
![]() |
WblockClone | Performs a shallow clone of this object. (Inherited from DBObject) |
![]() |
WorldDraw | Creates a viewport-independent geometric representation of this
object. (Inherited from Drawable) |
![]() |
X | (Inherited from RXObject) |
![]() |
XDataTransformBy | Applies the 3D transformation matrix to the XData of this
object. (Inherited from DBObject) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject) |
![]() |
Copied | Notification event called whenever the notifying object has had
its clone() member function called. (Inherited from DBObject) |
![]() |
Erased | Notification event called whenever an object has been erased or
unerased. (Inherited from DBObject) |
![]() |
Goodbye | Notification event called just before an object is deleted from
memory. (Inherited from DBObject) |
![]() |
Modified | Notification event called whenever an object is opened
ForWrite, a function has been called that
could modify the content of this object, and this object is now
being closed. (Inherited from DBObject) |
![]() |
ModifiedXData | Notification event called whenever the XData has been written
to the notifying object. (Inherited from DBObject) |
![]() |
ModifyUndone | Notification event called whenever the notifying object is
currently performing an undo operation that is undoing
modifications. (Inherited from DBObject) |
![]() |
ObjectClosed | Notification event called immediately before an object is
closed. (Inherited from DBObject) |
![]() |
OpenedForModify | Notification event called whenever an object is opened for
modifying ForWrite. (Inherited from DBObject) |
![]() |
Reappended | Notification event called whenever a redo process processes the
reappending of the notifying object to the database. (Inherited from DBObject) |
![]() |
SubObjectModified | (Inherited from DBObject) |
![]() |
Unappended | Notification event called whenever the undo process processes
the appending of the notifying object to the database. (Inherited from DBObject) |
© Bricsys NV. All rights reserved. |