OpenCloseTransactionAddNewlyCreatedDBObject
Method
|
Adds a newly created database record
object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public override void AddNewlyCreatedDBObject(
DBObject obj,
bool add
)
Public Overrides Sub AddNewlyCreatedDBObject (
obj As DBObject,
add As Boolean
)
public:
virtual void AddNewlyCreatedDBObject(
DBObject^ obj,
bool add
) override
abstract AddNewlyCreatedDBObject :
obj : DBObject *
add : bool -> unit
override AddNewlyCreatedDBObject :
obj : DBObject *
add : bool -> unit
Parameters
- obj DBObject
- [in] Object to add or remove.
- add Boolean
- [in] Flag that specifies whether to add or remove the
object.
Return Value
eok.
Remarks
The obj parameter must correspond to a newly created
object that has never been closed. The object also must be a
database resident (in other words, added to a database and has an
object identifier). The add and remove operations are performed on
the top transaction object.
See Also