OpenCloseTransaction Class

This .NET class wraps the OdMgOpenCloseTransaction class. The OpenCloseTransaction class may be used instead of the Transaction class in certain scenarios. It wraps the ObjectId.Open/Close methods but makes it easier to correctly pair these methods by storing references to every object opened and automatically closing them.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesTransaction
          Teigha.DatabaseServicesOpenCloseTransaction

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class OpenCloseTransaction : Transaction

The OpenCloseTransaction type exposes the following members.

Constructors
  Name Description
Public method OpenCloseTransaction Default constructor for the OpenCloseTransaction class. Creates the OpenCloseTransaction object based on the underlying C++ OdMgOpenCloseTransaction class.
Top
Properties
  Name Description
Public property TransactionManager Represents the transaction manager associated with this transaction.
(Overrides TransactionTransactionManager)
Top
Methods
  Name Description
Public method Abort Aborts the currently open transaction. This method initiates a rollback of all changes to objects since the start of the transaction.
(Overrides TransactionAbort)
Public method AddNewlyCreatedDBObject Adds a newly created database record object.
(Overrides TransactionAddNewlyCreatedDBObject(DBObject, Boolean))
Public method Commit Commits the changes made to all objects opened during the OpenCloseTransaction, and then closes them.
(Overrides TransactionCommit)
Protected method DeleteUnmanagedObject
(Overrides TransactionDeleteUnmanagedObject)
Public method GetObject(ObjectId, OpenMode) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
(Overrides TransactionGetObject(ObjectId, OpenMode))
Public method GetObject(ObjectId, OpenMode, Boolean) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
(Overrides TransactionGetObject(ObjectId, OpenMode, Boolean))
Public method GetObject(ObjectId, OpenMode, Boolean, Boolean) Calls the OpenObject() method of the underlying C++ object for the passed id within the specified open mode.
(Overrides TransactionGetObject(ObjectId, OpenMode, Boolean, Boolean))
Top
See Also

©  Bricsys NV. All rights reserved.