NurbSurfaceIsPlanar Method

Checks whether the surface is planar. If the surface is planar, also receives the plane information and normal.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public bool IsPlanar(
        out Point3d ptOnSurface,
        out Vector3d normal
)

Parameters

ptOnSurface  Point3d
[out] Receives the point on the surface (if the surface is planar).
normal  Vector3d
[out] Receives the plane normal (if the surface is planar).

Return Value

Boolean
true if this surface is planar, false otherwise.
Remarks
If the surface doesn't contain any NURBS information, the method throws the eFail exception.
See Also

©  Bricsys NV. All rights reserved.