Component
|
The ComponentDefinition type exposes the following members.
Name | Description | |
---|---|---|
![]() |
ComponentDefinition | Initializes a new instance of the ComponentDefinition class |
![]() |
ComponentDefinition(ComponentDefinition) | Initializes a new instance of the ComponentDefinition class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
BlockId | |
![]() |
BomStatus | |
![]() |
ComponentType | |
![]() |
Description | |
![]() |
FileStatus | |
![]() |
GetFilePath | |
![]() |
IsArray | |
![]() |
IsArraySource | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsExternal | |
![]() |
IsOriginal | |
![]() |
IsRoot | |
![]() |
IsSectionable | |
![]() |
IsStandard | |
![]() |
IsUpToDate | |
![]() |
Material | |
![]() |
Name | |
![]() |
OriginalBlockId | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() ![]() |
GetComponentDefinition | |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetStandardPartInfo | |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
InstanceBlockRefIds | |
![]() |
IsNull | |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
SetNull | |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
UndefineMech |
© Bricsys NV. All rights reserved. |