Explodes this entity into a set of simpler
entities.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Explode(
DBObjectCollection entitySet
)
Public Overridable Sub Explode (
entitySet As DBObjectCollection
)
public:
virtual void Explode(
DBObjectCollection^ entitySet
)
abstract Explode :
entitySet : DBObjectCollection -> unit
override Explode :
entitySet : DBObjectCollection -> unit
Parameters
- entitySet DBObjectCollection
- [in/out] Receives a collection of new entities. May contain
elements before method execution; new elements are appended to the
end of the collection.
Remarks
Entities resulting
from the explosion are appended to the specified collection. The
newly created entities are not database-resident. The default
implementation of this method throws the eNotApplicable exception. This method can be
overridden in custom classes.
See Also