CurveCurveIntersector2d(Curve2d,
Curve2d, Interval, Interval) Constructor
|
Constructor for the CurveCurveIntersector2d
class. Creates an intersector with two passed curves limited by the
specified intervals.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CurveCurveIntersector2d(
Curve2d curve1,
Curve2d curve2,
Interval range1,
Interval range2
)
Public Sub New (
curve1 As Curve2d,
curve2 As Curve2d,
range1 As Interval,
range2 As Interval
)
public:
CurveCurveIntersector2d(
Curve2d^ curve1,
Curve2d^ curve2,
Interval^ range1,
Interval^ range2
)
new :
curve1 : Curve2d *
curve2 : Curve2d *
range1 : Interval *
range2 : Interval -> CurveCurveIntersector2d
Parameters
- curve1 Curve2d
- [in] First curve for intersection.
- curve2 Curve2d
- [in] Second curve for intersection.
- range1 Interval
- [in] Interval range of the first curve.
- range2 Interval
- [in] Interval range of the second curve.
See Also