CurveCurveIntersector2d Class

This class represents intersections of 2D curves.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurveCurveIntersector2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class CurveCurveIntersector2d : Entity2d

The CurveCurveIntersector2d type exposes the following members.

Constructors
  Name Description
Public method CurveCurveIntersector2d Default constructor for the CurveCurveIntersector2d class. Creates a default corresponding C++ object with intersection curves set to NULL, default tolerance, and the flag that indicates whether data is initialized is set to false.
Public method CurveCurveIntersector2d(IntPtr) Constructor for the CurveCurveIntersector2d class. Creates an object based on the passed pointer.
Public method CurveCurveIntersector2d(Curve2d, Curve2d) Constructor for the CurveCurveIntersector2d class. Creates an intersector with two passed curves.
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Tolerance) Constructor for the CurveCurveIntersector2d class. Creates an intersector with two passed curves and geometric tolerance.
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval) Constructor for the CurveCurveIntersector2d class. Creates an intersector with two passed curves limited by the specified intervals.
Public method CurveCurveIntersector2d(Curve2d, Curve2d, Interval, Interval, Tolerance) Constructor for the CurveCurveIntersector2d class. Creates an intersector with two passed curves limited by the specified intervals.
Top
Properties
Methods
  Name Description
Public method ChangeCurveOrder Swaps the curve order of the intersector (makes first curve the second and vice versa).
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetIntersectionParameters Returns intersection parameters of two intersection curves at the specified point of intersection.
Public method GetIntersectionPoint Returns a 2D point at the specified number of intersection point.
Public method GetIntersectionPointTolerance Returns the geometric tolerance used to compute the specified intersection point.
Public method GetIntersectionRanges Gets the intersection ranges of two curves.
Public method GetOverlapRanges Gets the overlap ranges of two curves at the specified overlap index.
Public method GetPointOnCurve1 Gets the specified intersection point as PointOnCurve2d on the first curve.
Public method GetPointOnCurve2 Gets the specified intersection point as PointOnCurve2d on the second curve.
Public method IsTangential Checks whether the curves are tangent at the specified intersection point.
Public method IsTransversal Checks whether the curves are transversal (crossed) at the specified intersection point.
Public method OrderWithRegardsTo1 Sorts the intersection points so they correspond to increasing parameter values of the first curve.
Public method OrderWithRegardsTo2 Sorts the intersection points so they correspond to increasing parameter values of the second curve.
Public method Set(Curve2d, Curve2d) Sets curves of this intersector.
Public method Set(Curve2d, Curve2d, Tolerance) Sets curves of this intersector according to a geometric tolerance.
Public method Set(Curve2d, Curve2d, Interval, Interval) Sets curves limited by the specified ranges for this intersector.
Public method Set(Curve2d, Curve2d, Interval, Interval, Tolerance) Sets curves limited by the specified ranges for this intersector.
Top
Remarks
The intersection object links to 2D curve objects but does not contain them. Calculation of the intersection is performed by a query function. If one of the curve objects is deleted, the intersection must be recalculated. For more information, see Working with Intersected Entities.
See Also

©  Bricsys NV. All rights reserved.