Vector3d Constructor

Overload List
  Name Description
Public method Vector3d(Double) Constructor for the Vector3d class. Creates a new vector with coordinates taken from the first three values of the passed array.
Public method Vector3d(PlanarEntity, Vector2d) Constructor for the Vector3d class. Creates a new vector in the coordinates of the plane: uAxis * vect.x + vAxis * vect.y where uAxis and vAxis are returned by plane.get(origin, uAxis, vAxis).
Public method Vector3d(Double, Double, Double) Constructor for the Vector3d class. Creates a new vector with coordinates specified by the x, y and z values.
Top
See Also