FeatureControlFrame(String, Point3d,
Vector3d, Vector3d) Constructor
|
Constructor for the FeatureControlFrame class.
Creates a feature frame control with the specified codes, insertion
point and orientation defined by the normalVector and x
parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public FeatureControlFrame(
string codes,
Point3d insertionPoint,
Vector3d normalVector,
Vector3d x
)
Public Sub New (
codes As String,
insertionPoint As Point3d,
normalVector As Vector3d,
x As Vector3d
)
public:
FeatureControlFrame(
String^ codes,
Point3d insertionPoint,
Vector3d normalVector,
Vector3d x
)
new :
codes : string *
insertionPoint : Point3d *
normalVector : Vector3d *
x : Vector3d -> FeatureControlFrame
Parameters
- codes String
- [in] Text of this feature control frame.
- insertionPoint Point3d
- [in] Insertion point.
- normalVector Vector3d
- [in] WCS normal to the plane of the feature control frame.
- x Vector3d
- [in] WCS x-axis direction vector of the feature control
frame.
Remarks
The following
escape sequences are used to specify the feature control frame:
SequenceMeaning\n new line {\\Fgdt;a} angularity {\\Fgdt;b}
perpendicularity {\\Fgdt;c} flatness {\\Fgdt;d} profile of a
surface {\\Fgdt;e} circularity {\\Fgdt;f} parallelism {\\Fgdt;g}
cylindricity {\\Fgdt;h} circular runout {\\Fgdt;i} symmetry
{\\Fgdt;j} positional (+) {\\Fgdt;k} profile of a line {\\Fgdt;l}
least material condition {\\Fgdt;m} maximum material condition
{\\Fgdt;n} diameter {\\Fgdt;p} positional(P) {\\Fgdt;r}
concentricity {\\Fgdt;s} regardless of feature size {\\Fgdt;t}
total runout {\\Fgdt;u} straightness %%v vertical side of frame box
The insertion point is the middle of the left edge of the feature
control frame.
See Also