Ray3d(Point3d, Vector3d) Constructor
|
Constructor for the Ray2d class. Creates a ray
with the specified point and vector.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Ray3d(
Point3d point,
Vector3d vec
)
Public Sub New (
point As Point3d,
vec As Vector3d
)
public:
Ray3d(
Point3d point,
Vector3d vec
)
new :
point : Point3d *
vec : Vector3d -> Ray3d
Parameters
- point Point3d
- [in] A point from which the ray is cast.
- vec Vector3d
- [in] Ray direction. This vector must have a non-zero
length.
See Also