Vector3dIsPerpendicularTo(Vector3d,
Tolerance) Method
|
Checks whether the passed vector is
perpendicular to this vector within a geometric tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPerpendicularTo(
Vector3d vector,
Tolerance tolerance
)
Public Function IsPerpendicularTo (
vector As Vector3d,
tolerance As Tolerance
) As Boolean
public:
bool IsPerpendicularTo(
Vector3d vector,
Tolerance tolerance
)
member IsPerpendicularTo :
vector : Vector3d *
tolerance : Tolerance -> bool
Parameters
- vector Vector3d
- [in] Any 3D vector.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
Returns true if and only if the passed vector is perpendicular to
this vector within the geometric tolerance.
See Also