CubicSplineCurve2d(Point2dCollection,
Vector2d, Vector2d, Tolerance) Constructor
|
Constructor for the CubicSplineCurve2d class.
Creates a cubic spline curve according to the passed
parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CubicSplineCurve2d(
Point2dCollection fitPoints,
Vector2d startDerivative,
Vector2d endDerivative,
Tolerance tolerance
)
Public Sub New (
fitPoints As Point2dCollection,
startDerivative As Vector2d,
endDerivative As Vector2d,
tolerance As Tolerance
)
public:
CubicSplineCurve2d(
Point2dCollection^ fitPoints,
Vector2d startDerivative,
Vector2d endDerivative,
Tolerance tolerance
)
new :
fitPoints : Point2dCollection *
startDerivative : Vector2d *
endDerivative : Vector2d *
tolerance : Tolerance -> CubicSplineCurve2d
Parameters
- fitPoints Point2dCollection
- [in] Array of fit points.
- startDerivative Vector2d
- [in] Starting derivative of the cubic spline curve.
- endDerivative Vector2d
- [in] Ending derivative of the cubic spline curve.
- tolerance Tolerance
- [in] Geometric tolerance.
See Also