AssocActionGetActionsDependentOnObject(DBObject,
Boolean, Boolean, ObjectIdCollection) Method
|
Retrieves the actions depending on the
specified database object.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static void GetActionsDependentOnObject(
DBObject dbObj,
bool readDependenciesWanted,
bool writeDependenciesWanted,
ObjectIdCollection actionIds
)
Public Shared Sub GetActionsDependentOnObject (
dbObj As DBObject,
readDependenciesWanted As Boolean,
writeDependenciesWanted As Boolean,
actionIds As ObjectIdCollection
)
public:
static void GetActionsDependentOnObject(
DBObject^ dbObj,
bool readDependenciesWanted,
bool writeDependenciesWanted,
ObjectIdCollection^ actionIds
)
static member GetActionsDependentOnObject :
dbObj : DBObject *
readDependenciesWanted : bool *
writeDependenciesWanted : bool *
actionIds : ObjectIdCollection -> unit
Parameters
- dbObj DBObject
- [in] Database object for which to retrieve dependent actions.
Must be opened at least for read operations.
- readDependenciesWanted Boolean
- [in] Flag that specifies whether actions that depend on the
object should be retrieved.
- writeDependenciesWanted Boolean
- [in] Flag that specifies whether actions that modify the object
should be retrieved.
- actionIds ObjectIdCollection
- [in] Identifiers of the dependent actions.
See Also