TableStyleGridLineWeight Method
|
Returns the grid lineweight for the specified
gridline type and row type.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual LineWeight GridLineWeight(
GridLineType gridLineType,
RowType rowType
)
Public Overridable Function GridLineWeight (
gridLineType As GridLineType,
rowType As RowType
) As LineWeight
public:
virtual LineWeight GridLineWeight(
GridLineType gridLineType,
RowType rowType
)
abstract GridLineWeight :
gridLineType : GridLineType *
rowType : RowType -> LineWeight
override GridLineWeight :
gridLineType : GridLineType *
rowType : RowType -> LineWeight
Parameters
- gridLineType GridLineType
-
- rowType RowType
-
Return Value
LineWeight
Grid lineweight value.
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal grid line of the table, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top grid lines.
HorizontalBottom 0x04 Bottom or top horizontal grid line of the
table, depending on the flow direction of the table rows (down or
up). VerticalLeft 0x08 The grid line at the left edge of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right grid lines. VerticalRight 0x20 The grid line at the right
edge of the table.
See Also