TypedValue Structure

This value type may contain objects of various types. The TypeCode property defines the type of the value. Instances of this class are used as tagged data in resulting buffers to provide a pair: code - value.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesTypedValue

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct TypedValue

The TypedValue type exposes the following members.

Constructors
  Name Description
Public method TypedValue(Int32) Constructor for the TypedValue structure.
Public method TypedValue(Int32, Object) Constructor for the TypedValue structure.
Top
Properties
  Name Description
Public property TypeCode Property that represents the type code of the value. The type of the value is defined by this property.
Public property Value Property that represents the value of this object.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(TypedValue, TypedValue) Equality operator for the TypedValue class. Checks whether the typed values are equal.
Public operatorStatic member Inequality(TypedValue, TypedValue) Equality operator for the TypedValue class. Checks whether the typed values are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.