CurveCurveIntersector3d(Curve3d,
Curve3d, Vector3d) Constructor
|
Constructor for the CurveCurveIntersector3d
class. Creates an intersector with two passed curves.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CurveCurveIntersector3d(
Curve3d curve1,
Curve3d curve2,
Vector3d planeNormal
)
Public Sub New (
curve1 As Curve3d,
curve2 As Curve3d,
planeNormal As Vector3d
)
public:
CurveCurveIntersector3d(
Curve3d^ curve1,
Curve3d^ curve2,
Vector3d planeNormal
)
new :
curve1 : Curve3d *
curve2 : Curve3d *
planeNormal : Vector3d -> CurveCurveIntersector3d
Parameters
- curve1 Curve3d
- [in] First curve for the intersection.
- curve2 Curve3d
- [in] Second curve for the intersection.
- planeNormal Vector3d
- [in] Optional normal to a plane to be used in the corresponding
C++ object getIntConfigs() method.
See Also