Curve2dGetNormalPoint(Point2d)
Method
|
Retrieves the point on this curve where normal
extends through the passed point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve2d GetNormalPoint(
Point2d point
)
Public Function GetNormalPoint (
point As Point2d
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
Point2d point
)
member GetNormalPoint :
point : Point2d -> PointOnCurve2d
Parameters
- point Point2d
- [in] Point for which corresponding point on this curve is
retrieved.
Return Value
PointOnCurve2d
Point whose normal passes through the input point.
See Also