PixelFormatInfo Structure

Represents data for pixel formatting.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfacePixelFormatInfo

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct PixelFormatInfo

The PixelFormatInfo type exposes the following members.

Properties
Methods
  Name Description
Public method is16bitBGR Checks whether the pixel format of this raster image object is 16-bit BGR.
Public method isBGR Checks whether the pixel format of this raster image is BGR.
Public method isBGRA Checks whether the pixel format of this raster image object is BGRA.
Public method isRGB Checks whether the pixel format of this raster image is RGB.
Public method isRGBA Checks whether the pixel format of this raster image object is RGBA.
Public method set16bitBGR Sets the pixel format of this raster image object to 16-bit BGR.
Public method setBGR Sets the pixel format of this raster image object to BGR.
Public method setBGRA Sets the pixel format of this raster image object to BGRA.
Public method setRGB Sets the pixel format of this raster image object to RGB.
Public method setRGBA Sets the pixel format of this raster image object to RGBA.
Top
Operators
  Name Description
Public operatorStatic member Equality(PixelFormatInfo, PixelFormatInfo) Equality operator for the PixelFormatInfo structure. Checks whether the passed pixel format data objects are equal.
Top
See Also

©  Bricsys NV. All rights reserved.