ViewAdd(Drawable, Model) Method

Adds the specified scene graph to this Viewport object.

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual bool Add(
        Drawable drawable,
        Model model
)

Parameters

drawable  Drawable
[in] Root of the scene graph.
model  Model
[in] Model object to which all scene graph notifications are to be directed.

Return Value

Boolean
Remarks
This function is intended to be used as follows: 1. Construct a scene graph of Drawable objects. Each object draws its children using Geometry::draw(). 2. With this function, add the root of the scene graph and the model that handles notifications to this Viewport object.
See Also

©  Bricsys NV. All rights reserved.