Arc(Point3d, Double, Double, Double) Constructor
|
Constructor for the Arc class. Constructs an
arc with the specified center, radius, and start and end
angles.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Arc(
Point3d center,
double radius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
radius As Double,
startAngle As Double,
endAngle As Double
)
public:
Arc(
Point3d center,
double radius,
double startAngle,
double endAngle
)
new :
center : Point3d *
radius : float *
startAngle : float *
endAngle : float -> Arc
Parameters
- center Point3d
- [in] Center of an arc.
- radius Double
- [in] Radius of an arc.
- startAngle Double
- [in] Start angle in radians.
- endAngle Double
- [in] End angle in radians.
See Also