ExtrudedSurfaceCreateExtrudedSurface Method

Creates an extruded surface by sweeping a planar curve, region, or planar surface in the direction of the given vector using a distance equal to the length of the vector.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void CreateExtrudedSurface(
        Entity sweepEnt,
        Vector3d directionVec,
        SweepOptions sweepOptions
)

Parameters

sweepEnt  Entity
[in] Curve, region, or planar surface to be swept.
directionVec  Vector3d
[in] A vector determining the distance and direction of the sweeping.
sweepOptions  SweepOptions
[in] Sweep options.
Remarks
Additional extruding parameters (for example, draft angle) can be specified with the sweepOptions object. This method is implemented only for Spatial modeler and throws the eNotImplementedYet exception for other modelers.
See Also

©  Bricsys NV. All rights reserved.