Spline(Point3dCollection, Vector3d,
Vector3d, Int32, Double) Constructor
|
Constructor for the Spline class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Spline(
Point3dCollection point,
Vector3d startTangent,
Vector3d endTangent,
int order,
double fitTolerance
)
Public Sub New (
point As Point3dCollection,
startTangent As Vector3d,
endTangent As Vector3d,
order As Integer,
fitTolerance As Double
)
public:
Spline(
Point3dCollection^ point,
Vector3d startTangent,
Vector3d endTangent,
int order,
double fitTolerance
)
new :
point : Point3dCollection *
startTangent : Vector3d *
endTangent : Vector3d *
order : int *
fitTolerance : float -> Spline
Parameters
- point Point3dCollection
- [in] Fit points.
- startTangent Vector3d
- [in] Start point tangent.
- endTangent Vector3d
- [in] End point tangent.
- order Int32
- [in] Spline degree (order).
- fitTolerance Double
- [in] Fit tolerance.
See Also