DatabaseInsert(Matrix3d, Database, Boolean)
Method
|
Copies the content of a specified database to
this database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Insert(
Matrix3d transform,
Database dataBase,
bool preserveSourceDatabase
)
Public Sub Insert (
transform As Matrix3d,
dataBase As Database,
preserveSourceDatabase As Boolean
)
public:
void Insert(
Matrix3d transform,
Database^ dataBase,
bool preserveSourceDatabase
)
member Insert :
transform : Matrix3d *
dataBase : Database *
preserveSourceDatabase : bool -> unit
Parameters
- transform Matrix3d
- [in] Transformation matrix applied to all copied objects.
- dataBase Database
- [in] Source database to copy data from.
- preserveSourceDatabase Boolean
- [in] Flag that specifies whether the source database is left
unchanged.
Remarks
Unlike the
wblockCloneObjects() method, insert() also copies the sortens
table. While copying duplicate objects, names are ignored; a
destination object that has the same name as the source object is
rewritten by the source one. All model space entities in
dataBase are copied into model space of
this database object and transformed by xfm. You should delete the
source database either immediately or at least before the
destination database is deleted.
See Also