Solid3dFilletEdges Method

Creates rounded fillets on the edges of the solid.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void FilletEdges(
        SubentityId[] subentityIds,
        DoubleCollection radius,
        DoubleCollection startSetback,
        DoubleCollection endSetback
)

Parameters

subentityIds  SubentityId
[in] Array of the edges' object IDs. Fillet is applied on the specified edges.
radius  DoubleCollection
[in] Array of fillet radius values for the corresponding edges.
startSetback  DoubleCollection
[in] Array of start setback values for the corresponding edges.
endSetback  DoubleCollection
[in] Array of end setback values for the corresponding edges.
Remarks
This method is implemented only for the Spatial modeler.
See Also

©  Bricsys NV. All rights reserved.