PixelBGRA32 Structure

This class defines pixel color parameters in RGB format, which stores an integer for red, green, and blue values, and also includes a value for alpha-shading.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfacePixelBGRA32

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct PixelBGRA32

The PixelBGRA32 type exposes the following members.

Constructors
  Name Description
Public method PixelBGRA32(IntPtr) Constructor for the PixelBGRA32 class. Creates an object based on the passed pointer.
Public method PixelBGRA32(UInt32) Constructor for the PixelBGRA32 class. Creates pixel data with the unsigned integer value in BGRA format. The preferred way is to use hexadecimal value.
Public method PixelBGRA32(Byte, Byte, Byte, Byte) Constructor for the PixelBGRA32 class. Creates pixel data with the specified blue, red, green and alpha values.
Top
Properties
  Name Description
Public property Alpha  
Public property Blue  
Public property Green  
Public property Red  
Top
Methods
  Name Description
Public method init Initializes blue, red and green components to 0 and the alpha component to 255.
Top
See Also

©  Bricsys NV. All rights reserved.