CircularArc2d(Point2d, Double, Double,
Double, Vector2d, Boolean) Constructor
|
Constructor for the CircularArc2d class.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CircularArc2d(
Point2d center,
double radius,
double startAngle,
double endAngle,
Vector2d referenceVector,
bool isClockWise
)
Public Sub New (
center As Point2d,
radius As Double,
startAngle As Double,
endAngle As Double,
referenceVector As Vector2d,
isClockWise As Boolean
)
public:
CircularArc2d(
Point2d center,
double radius,
double startAngle,
double endAngle,
Vector2d referenceVector,
bool isClockWise
)
new :
center : Point2d *
radius : float *
startAngle : float *
endAngle : float *
referenceVector : Vector2d *
isClockWise : bool -> CircularArc2d
Parameters
- center Point2d
- [in] Center of an arc.
- radius Double
- [in] Radius of an arc.
- startAngle Double
- [in] Start angle of an arc.
- endAngle Double
- [in] End angle of an arc.
- referenceVector Vector2d
- [in] The reference vector defining arc angle 0.
- isClockWise Boolean
- [in] Specifies whether the circular arc is oriented
clockwise.
Remarks
The constructor
creates a circular arc with the specified parameters. To construct
a circle, set endAng = startAng + Oda2PI. All angles are expressed
in radians. The start angle must be less than the end angle.
See Also