EllipticalConeSet(Double, Double,
Point3d, Double, Double, Vector3d) Method
|
Sets the specified cosine and sine of the half
angle, base center, radii, and axis of symmetry.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry
)
Public Sub Set (
cosineAngle As Double,
sineAngle As Double,
baseCenter As Point3d,
minorRadius As Double,
majorRadius As Double,
axisOfSymmetry As Vector3d
)
public:
void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry
)
member Set :
cosineAngle : float *
sineAngle : float *
baseCenter : Point3d *
minorRadius : float *
majorRadius : float *
axisOfSymmetry : Vector3d -> unit
Parameters
- cosineAngle Double
- [in] The cosine of the angle between the generating line
passing through the major axis and the axis of symmetry.
- sineAngle Double
- [in] The sine of the angle between the generating line passing
through the major axis and the axis of symmetry.
- baseCenter Point3d
- [in] The origin point of this elliptical cone.
- minorRadius Double
- [in] The minor radius of this elliptical cone.
- majorRadius Double
- [in] The major radius of this elliptical cone.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
See Also