Elliptical
|
The EllipticalCone type exposes the following members.
Name | Description | |
---|---|---|
![]() |
EllipticalCone | Default constructor for the EllipticalCone class. Creates a default corresponding C++ object with cosine angle equal to cos(OdaPI/4.0), sine angle equal to -sin(OdaPI/4.0), base origin at the origin of the world coordinate system, 1.0 for major and minor radii, and OdGeVector3d::kYAxis for the axis of symmetry. |
![]() |
EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d) | Constructor for the EllipticalCone class. Creates an object with specified cosine and sine angles, base origin, minor and major radii, and axis of symmetry. |
![]() |
EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d, Vector3d, Interval, Double, Double) | Constructor for the EllipticalCone class. Creates an object with specified cosine and sine angles, base origin, minor and major radii, axis of symmetry, height interval, and start and end angles. |
Name | Description | |
---|---|---|
![]() |
Apex | |
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
AxisOfSymmetry | |
![]() |
BaseCenter | |
![]() |
HalfAngle | |
![]() |
Height | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsNormalReversed | Property that indicates whether the normal of this surface is
reversed an odd number of times. (Inherited from Surface) |
![]() |
IsOuterNormal | |
![]() |
MajorAxis | |
![]() |
MajorRadius | |
![]() |
MinorAxis | |
![]() |
MinorRadius | |
![]() |
RadiusRatio | |
![]() |
ReverseNormal | Property that creates a surface with a reversed normal vector
orientation (the same exact surface but with changed normal
orientation). (Inherited from Surface) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | Clones this entity and returns a handle to the cloned
entity. (Inherited from Entity3d) |
![]() |
ClosestPointTo(Point3d) | Gets a point on this surface that is the closest to the
specified point. (Inherited from Surface) |
![]() |
ClosestPointTo(Point3d, Tolerance) | Gets a point on this surface that is the closest to the
specified point according to a tolerance. (Inherited from Surface) |
![]() ![]() |
Create | Creates an object based on the passed pointer and returns a handle to the created object. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
DistanceTo(Point3d) | Retrieves the distance from the closest point on this plane to
the specified point. (Inherited from Surface) |
![]() |
DistanceTo(Point3d, Tolerance) | Retrieves the distance from the closest point on this plane to
the specified point according to a tolerance. (Inherited from Surface) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
EvaluatePoint | Retrieves the 3D point on this surface that corresponds to the
specified point parameter value. (Inherited from Surface) |
![]() |
GetAngles | Gets the start and end angles of this elliptical cone. |
![]() |
GetClosestPointTo(Point3d) | Gets a point on this surface that is the closest to the
specified point. (Inherited from Surface) |
![]() |
GetClosestPointTo(Point3d, Tolerance) | Gets a point on this surface that is the closest to the
specified point according to a tolerance. (Inherited from Surface) |
![]() |
GetEnvelope | (Inherited from Surface) |
![]() |
GetHalfAngles | Gets the angle between the generating line passing through the major axis and the axis of symmetry. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetHeightAt | Returns the height of this elliptical cone corresponding to the specified position on the U-axis (parameter). |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
IsClosed | Checks whether the base of this elliptical cone is a full ellipse. |
![]() |
IsClosed(Tolerance) | Checks whether the base of this elliptical cone is a full ellipse within the specified tolerance. |
![]() |
IsClosedInU | (Inherited from Surface) |
![]() |
IsClosedInU(Tolerance) | (Inherited from Surface) |
![]() |
IsClosedInV | (Inherited from Surface) |
![]() |
IsClosedInV(Tolerance) | (Inherited from Surface) |
![]() |
IsEqualTo(Entity3d) | Checks whether this entity is equal to the specified
entity. (Inherited from Entity3d) |
![]() |
IsEqualTo(Entity3d, Tolerance) | Checks whether this entity is equal to the specified entity
within a geometric tolerance. (Inherited from Entity3d) |
![]() |
IsOn(Point3d) | Checks whether the specified point is on this entity. (Inherited from Entity3d) |
![]() |
IsOn(Point3d, Tolerance) | Checks whether the specified point is on this entity according
to a geometric tolerance. (Inherited from Entity3d) |
![]() |
IsOn(Point3d, Point2d) | (Inherited from Surface) |
![]() |
IsOn(Point3d, Point2d, Tolerance) | (Inherited from Surface) |
![]() |
Mirror | Mirrors this entity about the specified plane. (Inherited from Entity3d) |
![]() |
ParameterOf(Point3d) | Retrieves a 2D point (U, V) that represents parametric values
for the passed 3D point on this surface. (Inherited from Surface) |
![]() |
ParameterOf(Point3d, Tolerance) | Retrieves a 2D point (U, V) that represents parametric values
for the passed 3D point on this surface. (Inherited from Surface) |
![]() |
RotateBy | Rotates this entity by the specified angle about the axis
defined by the point and the vector. (Inherited from Entity3d) |
![]() |
ScaleBy | Scales this entity by the scale factor about the specified
point. (Inherited from Entity3d) |
![]() |
Set(Double, Double, Point3d, Double, Double, Vector3d) | Sets the specified cosine and sine of the half angle, base center, radii, and axis of symmetry. |
![]() |
Set(Double, Double, Point3d, Double, Double, Vector3d, Vector3d, Interval, Double, Double) | Sets the specified cosine and sine of the half angle, base center, radii, axis of symmetry, height interval, and start and end angles. |
![]() |
SetAngles | Sets the start and end angles of this elliptical cone. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TransformBy | Applies the specified 2D transformation matrix to this
entity. (Inherited from Entity3d) |
![]() |
TranslateBy | Translates this entity by applying a 3D translation
vector. (Inherited from Entity3d) |
© Bricsys NV. All rights reserved. |