RotatedDimension(Double, Point3d, Point3d, Point3d, String, ObjectId) Constructor

Constructor. Creates a RadialDimensionLarge object with specified parameters.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public RotatedDimension(
        double rotation,
        Point3d line1Point,
        Point3d line2Point,
        Point3d dimensionLinePoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

rotation  Double
[in] Rotation angle in radians.
line1Point  Point3d
[in] First extension point. The point from which the length is measured and the first extension line begins.
line2Point  Point3d
[in] Second extension point. The point from which the length is measured and the second extension line begins.
dimensionLinePoint  Point3d
[in] Point on the dimension line.
dimensionText  String
[in] Dimension text to replace the measured value text.
dimensionStyle  ObjectId
[in] ObjectId of the dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.